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Introduction  

Byos hosts a number of workflows incorporating peptide analysis that can be used for peptide-centric 
analysis of protein samples. From late discovery through clinical development, Peptide workflows in Byos 
are used for Protein Characterization and Multi-Attribute Methods (MAM). 

Using the Peptide workflows available in Byos, researchers can confidently characterize their product 
down to trace components and reduce turn-around time by weeks. Dynamic, Editable reports for non-
mass spectrometry stakeholders for internal review or for application filings are automatically linked to 
projects..  

The software considers LC-MS and LC-MS/MS results and enables label-free quantification, easy 
inspection of results, and reporting on summary and detail information for a variety of workflows that rely 
on peptide-level analysis.  The raw data (MS1 recorded in profile or centroid mode) can originate from any 
major mass spectrometry vendor (Thermo Fisher Scientific™, Waters™, SCIEX™, Bruker™, Shimadzu™, 
or Agilent Technologies™). 

Byos supports the analysis of a wide range of degradants, variants, and post-translational modifications 
(PTM). Workflows for PTM analysis, peptide mapping, hotspot analysis, stress studies, MAM profiling, 
host cell protein analysis, glyco analysis, disulfide bond profiling, comparability, oxidative footprinting, and 
more are available, providing a powerful platform for comparing and reporting across samples.  More than 
one type of digestion enzyme may be examined at once, and each may include multiple LC-MS data 
acquisitions and multiple MS2 searches from any data acquisition.  The fragmentation method may be any 
combination of low-energy CID, HCD/Q-TOF, and/or ETD. The quantification of a modification or variant 
relative to wildtype is performed by label-free quantification with extracted ion chromatograms (XICs), 
which have editable limits of integration.   

Using Byos for peptide analysis enables the analyst to determine if a putative identification is true or false 
(validation) by making available all relevant information interactively in a single screen.  This empowers 
the user to make this decision and add their own comments, rather than a black-box software algorithm. 
The application also makes room for one or more reviewers to enter their responses and comments.  
Comprehensive reports of results (tables and figures) may be exported for report generation to share with 
colleagues.   

Analyses may also be deployed into a fully automated workflow to process large numbers of samples with 
consistent analysis and reporting. 

Windows Support 

Byos Desktop is currently supported on Windows 10 and Windows 11. Note that for Windows 10, you 
must have version 1809 or later.  

System Specifications 

• Recommended PC: 
o Windows 10/11 64-bit  
o 32 GB RAM 
o 1TB disk space (Solid State SSD) 
o Recent version of Intel Core i7 or i9 / AMD Ryzen 7 or 9 (with AVX support) 
o Oracle JRE or OpenJDK 
o C++ compiler version 16 or higher 

• Recommend PC for high performance computing (e.g. 32+ cores) 
o Windows Server 2022 or Windows 10/11 
o 64 GB RAM 
o 2 TB disk space (Solid State SSD) 
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o Xeon CPU(s) (at least 16 physical cores) (with AVX support) 
o Oracle JRE or OpenJDK 
o C++ compiler version 16 or higher 

Note that standalone applications are no longer supported outside of Byos and that Peptide Analysis is 
performed using Byos workflows. 

Raw mass spec data are accepted from these vendors: Thermo Fisher, Waters, Sciex, Bruker, or Agilent. 
Optical data may be embedded in these files or imported via a *.csv file of time-intensity data pairs 

Launching a Preset Workflow in Byos 

To create a new analysis, go to the workflows tab and select a PTM workflow if you are performing a 
peptide map of a purified biotherapeutic protein with an MSMS search. Byos will open the workflow. 

 

Figure 1: Default PTM workflow 

This multi-tab window allows the analyst to select multiple mass spectrometer files to be analyzed, each 
with one or more set of MS/MS search results, as well as a corresponding set of protein sequences. 

Tour of Peptide Analysis Dashboard Views 

The Peptide Analysis user interface (UI), or dashboard, shown in the figure below has seven highly 
interactive plot and table views: 
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Figure 2: Peptide Analysis Dashboard 

Six Peptide Analysis views: (1) Project table, (2) Protein coverage table, (3) Peptides table, (4) Ion 
chromatogram (XIC) plots, (5) MS2 and mass error plots, and (6) Isotope plots. Views can be 
rearranged, resized, docked, and undocked. Customized layouts can be saved and shared.   

1. The Project view lists the data files in use. The paired check boxes for MS files and result 
files can be used to turn on or off the records displayed in the other views. The colors of the 
files correspond to colors used in the other views. 

2. The Protein Coverage views display table data and identify sequences for peptides 
selected and filtered in the Peptides table in View 3. Bars below the sequences represent 
MS/MS scans. The bars and sequences share the colors of the corresponding MS files in 
the Project table in View 1. 

3. The Peptides table lists all identified and filtered peptides. Selecting a peptide row in the 
table displays the corresponding wildtype peptides, XIC chromatograms, MS2 and mass 
error plots, and isotope plots in Views 4 through 7. 

4. The XIC plots show the ion chromatograms for the peptide and corresponding wildtype 
peptides, if present, selected in the Peptides table in View 3. The plots are shaded with the 
colors of the source MS files in the Project table in View 1. 

5. The MS2 and mass error plots show the MS2 spectrum of the peptide and corresponding 
wildtype peptides, if present, selected in the Peptides table in View 3. The peptide and 
wildtype peptide spectra share the same m/z scaling for easy comparison.  

6. The Isotopes plots show the MS1 isotope spread of the peptide and corresponding 
wildtype peptides, if present, selected in the Peptides table in View 3.  

The Wildtype peptides table lists wildtype peptides corresponding to the modified peptides selected in 
the Peptides table in View 3. Records are shaded with the colors of the source MS files in the Project 
table in View 1. This table is displayed when Windows > Show Wildtype is checked. 

In the default mode, the Chromatogram XIC Plot displays the Total Ion Current (TIC) and Extracted Ion 
Chromatogram (XIC) of a specific peptide. With advanced settings as described in Chromatogram XIC 
Plot and Menu section, Summed Extracted Ion Chromatograms (XIC summed) of one or multiple peptides 

https://docs.google.com/document/d/1WaqPASfelNAfQ33ee1K99Q9ypn_WJd_pfAhueSyBsFc/edit?pli=1#heading=h.2r0uhxc
https://docs.google.com/document/d/1WaqPASfelNAfQ33ee1K99Q9ypn_WJd_pfAhueSyBsFc/edit?pli=1#heading=h.2r0uhxc
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eluting at a given time, and the Total Ion Current difference (TIC difference) can also be overlayed on the 
XIC plot. To open the Chromatogram XIC plot, choose Window > Show Chromatogram XIC Plot. 

Project Creation options 

The following section details parameters in Project Creation for Peptide projects. These parameters are 
therefore relevant to the HCP, HotSpot, PTM, PTM (in-silico), SVA (C57) – Specific, SVA (C58) – 
Specific, S-S, System Suitability, Oxidative Footprinting, and MAM New Peak Detection workflows. 

Samples 

The Samples tab allows the user to load raw LC-MS sample files into the project. Byos accepts a variety 
of sample file types (Bruker: *.d, Agilent: *.d, Thermo: *.raw, Waters: *.raw, Sciex: *.wiff, *.wiff2, Shimadzu 
*.lcd . Alternatively, a project can be opened from a *.byrslt file generated from a previous Byonic™ search. 
To load a file, drag and drop one or more MS files into the project window. Alternatively, click the Add 

sample button, double-click on the new row under the MS file header, click   and browse to the file. 
Click Open. 

 

Figure 3: Sample input tab 

Sample name defaults to the file name. To change the Sample name, double-click the name and edit the 
text. The name can also be updated later in the Project table.  

To designate the enzyme used by a sample, double-click the sample row under Digestion and select the 
enzyme name. This enables Byos to determine the expected cleavage sites.  
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Figure 4: Digestion enzyme selection 

To apply the Digestion term to multiple Sample rows, select the group of Digestion cells, right-click Edit 
selected rows, select or enter the Digestion term, and click OK. Alternatively, copy the term from one cell, 
click each Digestion cell in turn, and past in the copied Digestion term. 

The user has an option to provide a combination of C-Term and N-term proteases as well, e.g., 
AspN_Trypsin @ D;R,K | N-term; C-term. 

To add an incremental MS/MS search result to a sample, double-click in that sample row under the MS/MS 

Search header, click   and browse to the MS/MS search result ( *.byrslt or *.dat) file. Click Open. To 
attach additional MS/MS search result to that sample, click  to add a new MS/MS Search row and repeat 
the addition steps.  

To remove an MS/MS search file, double-click the file name and click . 
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Sequences 

 

Figure 5: Sequences tab 

It is also possible to define or import custom protein annotations during Project Creation within the 
Sequences tab. 

 

Figure 6: Protein Annotations 
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There is also an option to import or export protein annotations after Project Creation in the Protein 
Annotations table. This feature has been implemented in a backward compatible fashion so that users 
can import annotations from CSV file created in previous versions. 

 

Figure 7: CSV options for Protein Annotations 

Processing nodes  

The Processing nodes tab is where the user specifies the processing parameters to be applied during 
project creation and report generation. Each workflow is populated with default values, designed for the 
user to review once and save for future projects. This empowers every member of a team, scientist within 
a lab, or colleagues across a project to complete the exact same analysis and generate identical reports 
regardless of Byos user-skill level, scientific expertise or experience, or location. Please note the next 
section will only have to be completed once for each analysis type and the workflow used for perpetuity. 
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Figure 8: Processing nodes for the PTM workflow 

NOTE: These parameters are not part of the PTM (in-silico) workflow. Please refer directly to the below 
Quant section. 

• General 

 

Figure 9: General. 

o Samples - The “*” will apply all parameters to all samples dragged and dropped into the 
Samples tab. 

o Results Folder Name creates a folder of that name to save results, set to “Byonic” by 
default. 

• Protein Database options 

 

 

Figure 10: Protein database options. 
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The protein database options Add Common Contaminants (default setting = No) and Add 
Decoys (default setting = Yes) were added to the Byonic Processing node in v. 3.9. The protein 
database should contain both targets and decoys (recognized by protein names beginning 
>Reverse or >Decoy) for false discovery rate (FDR) estimation. Byonic will automatically add 
decoys if the Add decoys box is checked and contaminant proteins (e.g., trypsin, bovine serum 
albumin, and human keratins) if the Add common contaminants box is checked. Typical 
folders to store input files are: C:\data_input\Mass_Spectra and 
C:\data_input\Protein_Databases. 

• Instrument Parameters 

 

Figure 11: Instrument Parameters. Optimize for the experiment completed. 

In the figure above, the user set 6.0 ppm Precursor Mass Tolerance, 20.00 ppm Fragment 
Mass Tolerance, and QTOF/HCD as the Fragmentation Type. Both Dalton and ppm mass 
tolerances for precursors and fragments are supported, along with several fragmentation types. 
The Dalton tolerance applies to measured mass for precursors but measured m/z for fragments. 
The way scoring is completed changes at fragment tolerances of 0.1 Da or 100 ppm or less: 
high-resolution MS/MS is assumed, meaning resolution sufficient to distinguish charge states of 
fragment ions. For this reason, fragment tolerances larger than 0.1 Da should be used with low-
resolution (ion trap) MS/MS analysis. 

Internal models for most fragmentation types are included – CID low energy (ion trap), QTOF / 
HCD (beam-type CID), and ETD / ECD (electron transfer and electron capture dissociation), as 
well as a number of combinations of types. These internal models determine which fragment 
peak types will be scored and annotated. For example, prominent c- and z-ions and small y-ions 
are expected for ETD. Prominent oxonium ions are expected from glycopeptides with QTOF / 
HCD fragmentation, but small or missing oxonium ions from CID low energy.  

o Precursor Mass Tolerance  

 

Figure 12: Precursor Mass Tolerance. 

The user can change this value by clicking within the text box and then clicking on the 
activated blue “…” square. The user can then modify the text value and mass accuracy, 
as required. .  

 

Figure 13: Modify the text value and mass accuracy. 

o Fragmentation Type 
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Figure 14: Fragmentation type. 

The user can select from the available options using the drop-down menu. Additional 
options are visible using the scroll bar, including “Both:” for spectrum file(s) containing 
more than one fragmentation type and “Use Thermo scan headers” to read directly from 
Thermo raw data files. 
 

o Fragment Mass Tolerance 1- The user can set the value used to acquire data in either 
ppm or Da. This is changed by editing Fragment Mass Tolerance 1 shown in Figure 11.  

o Fragment Mass Tolerance 2 - If necessary, the user can set the value used to acquire data 
in either ppm or Da. This is only required for the “Both:” Fragmentation Types (selected as 
shown in Figure 11 above – the final entries). The user can set the value used to acquire 
data in either ppm or Da. No value will be applied if only a value for “Fragmentation Mass 
Tolerance 1” was entered.  

o Recalibration (lock mass)  

 

Figure 15: Lock mass calibration options. 

The user can select from the available options using the drop-down menu. 

• Digestion 

 

Figure 16: Digestion options. 



Peptide Analysis Manual v5.12                                         

 

12 

 

The Digestion settings allow the user to set the residues recognized by the digestion enzyme. In 
this example, the enzyme is trypsin, so the user entered RK for arginine and lysine for the 
Cleavage Site(s) and chose C-terminal for the Cleavage Side.  

o Cleavage Site(s) - The user can change this value by entering text. If the user leaves the 
Cleavage Site(s) box empty, the only specific cleavage sites are protein termini. 

o Cleavage Side 

 

Figure 17: Cleavage Side options. 

The user can change this by selecting another option from a drop-down menu. Click on 
the current selection to activate the drop-down menu to view the available options.  

o Digestion Specificity 

 

Figure 18: Digestion Specificity 

In the figure above, the user chose a “Fully specific (fastest)” search, meaning that both 
the N- and C-terminal cleavages must be C-terminal to R or K. Nonspecific cleavage at 
either or both endpoints is supported. A nonspecific search with RK in the Cleavage 
Site(s) box searches all peptides but favors tryptic peptides; the user must leave the 
Cleavage Site(s) box empty for a true no-enzyme search. Digestion Specificity can be 
changed by selecting another option from a drop-down menu. The user can click on the 
current selection to activate the drop-down menu to view the available options.  

o Missed Cleavages - The user selected 2 Missed Cleavages, as shown in Figure 16. This 
limits the maximum number of internal Rs and Ks not followed by P to 2; leaving Missed 
Cleavages at its default value of -1, which means any number of internal Rs and Ks. Missed 
Cleavages can be changed by entering text. 

• Modifications 

 

 

Figure 19: Modifications options 

Two categories of modifications are defined: fixed and variable. A fixed modification is assumed 
to occur on all the residues of that type, but a variable modification is optional, so that each site 
for a variable modification is considered with and without the modification. 

o Modifications 
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Figure 20: Click within the text box to activate the light blue “…”button 

To view the list of modifications included with the default workflow, the user can click 
within the text box to activate the light blue “…”button.. 

The user can specify any number of modification rules via a pull-down menu containing 
all the modifications listed in www.unimod.org. For convenience, frequently used 
modifications are listed twice, at the top and again in the complete list. The three pull-
down menus in each row select modification type, target residues, and fine control. 
There is a fourth pull-down, which lets the user delete, invert (as in 
(De)Carbamidomethyl), or add “attributes” to modifications. Attributes allow the user to 
define protein-specific modifications. 

 

Figure 21: Select Modifications window 

o Total Common Max and Total Rare Max - Protein Metrics uniquely provides a feature that 
dramatically increases search efficiency: the user designates each variable modification as 
either “common” or “rare”, with the names suggesting their use. The user can define 
separate limits on the number of occurrences of each variable modification, so that 
“common 2” means at most two occurrences per peptides. Separate limits can also be set 
for the total number of common and rare modifications per peptide. A typical search allows a 
total of at most two common modifications and a total of at most one rare modification per 
peptide. To search for, say, three phosphoserines per peptide, the user can change Total 
common modification max to 3 or split phosphorylated serine between two rules: common2 
and rare1. Depending upon the other modification rules, the latter approach may give a 

http://www.unimod.org/
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faster search. Please review the “Modification Fine Control” Application Note available at 
https://www.proteinmetrics.com/resources/.  

NOTE: The single most important factor in search time is Total Common Max (shown 
inFigure 19). Roughly speaking, the search time grows as C*T where C is the number of 
common modifications enabled and T is Total Common Max. 

Conceptually, the search engine has one modification “slot” for each residue, along with 
slots for the peptide’s N- and C-termini. A variable modification such as +0.984016 @ N 
uses up the residue slot; a nonspecific terminal modification such as +57.021464 @ 
NTerm uses up the terminal slot; but residue-specific N-terminal modifications, such as -
17.026549 @ NTerm Q, use up both the residue and the N-terminal slots. 

The big open box (shown in the figure above) is a space for the user to type in custom 
modifications not listed in Unimod. The manual fine control format has the form: 

Modification_Name / Mass_Delta @ Targets | Fine_Control 

Modification_Name / is optional. The Targets field allows the 20 one-letter amino acid 
abbreviations, as well as four special locations: NTerm, CTerm, Protein NTerm, and 
Protein CTerm. NTerm, CTerm, Protein NTerm, and Protein CTerm can also be used as 
modifiers of amino acid residues. Targets form a comma-separated list.  

Here is an example of a real modification not (yet) in Unimod: 

DehydroFormyl / +9.98435 @ NTerm S, NTerm T | rare1 

A limited number of nonstandard amino acid residues can be supported by redefining 
one-letter amino acid abbreviations using fixed modifications. B, Z, U, O, J, and X are 
accepted within FASTA protein databases, with masses, respectively, of 114.042927 
(same as N), 128.058578 (same as Q), 150.95363 (selenocysteine), 237.052645 
(pyrrolysine), 100.0, and 110.05 (close to averagine). By placing, for example, a fixed 
modification of +13.04768 on J, the user can make J in a FASTA database have mass 
113.04768, correct for hydroxyproline. However, the amino acid sequence is used to 
predict peak intensity, so this fixed modification on J will not give the same scores as a 
+15.9949 variable modification on P. 

For comprehensive sequence variant searches, or other searches with large numbers of 
modifications, it is more convenient to paste in a list of modifications in the custom 
modification box than to add all the modifications via the drop-down menus. Sequence 
variant lists are available from Protein Metrics by contacting 
support@proteinmetrics.com. 

• Glycans 

 

Figure 22: Glycans are now loaded as a list of records 

Three ways to define glycan modifications are offered: internal preset tables, external glycan 
databases, and user-defined glycans. Click the activated light blue “…” button to pop up a 
window labeled Select Glycans:  

https://www.proteinmetrics.com/resources/
mailto:support@proteinmetrics.com
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Figure 23: The Select Glycans 

Import populates the dialog with a list of glycans from a glycan database text file: 

 

Figure 24: Importing glycan databases included with installation 

Click the dropdown arror to choose a glycan DB file. The dropdown displays a list of 
glycan database text files found in C:\Program Files\ProteinMetrics\PMI-
Suite\Base\data\GlycanDatabases. These text files can be edited, and new glycan 
database text files can be added to the directory, where they become available in the 
dropdown (after closing and reopening Byos). This set of glycan databases is continually 
updated based on customer feedback. Please reach out to support@proteinmetrics.com 
to request additional content. 

Alternatively, click the “…” button to open a custom glycan DB file from a different 
directory. The user can choose the Glycan type (N- or O-linked) and then set the Fine 
Control (rare1, common2, etc.).  

 

mailto:support@proteinmetrics.com


Peptide Analysis Manual v5.12                                         

 

16 

 

Figure 25: Glycan Fine Control options 

The text files include one glycan composition per line; for example, the following gives 
five of the most common human O-glycans. Spaces between monosaccharides are 
optional, and unused monosaccharides can be left out or included with zero (0) 
occurrences. 

HexNAc(1) Hex(0) 
HexNAc(1) Hex(1) Fuc(0) NeuAc(0) 
HexNAc(1)Hex(1)Fuc(0)NeuAc(1)NeuGc(0)Na(0) 
HexNAc(1)Hex(1)Fuc(0)NeuAc(2)NeuGc(0)Na(0) 
HexNAc(1)Hex(1)Fuc(1)NeuAc(0)NeuGc(0)Na(0) 

Add opens the Edit Glycan dialog to create glycans from internal preset tables: .  

 

Figure 26: Edit glycans. 

Enter the count of each used monosaccharide. Six monosaccharide residues are 
allowed: HexNAc, Hexose, Fucose, Pentose (common in plants), NeuAc, and NeuGc 
(common in non-humans). There is also a box for Sodium because it is a common 
adduct on sialic acids. Unused monosaccharides can be left blank or included with zero 
(0) occurrences. Other glycan masses and modifications such as sulfation and 
acetylation can be defined with the Additional mass box; this mass is added to the mass 
of the monosaccharides. The total delta mass will automatically populate to six decimal 
places. Click Ok to load the glycan to the Select Glycans dialog. Edit the Glycan Type 
and Fine Control, as needed:. 

 

Figure 27: Glycans assembled from monosaccharides 

A third way to enter glycans is to enter or paste glycan text in the Enter custom glycan text 
in fine control format box at the bottom. These glycans are entered using the same 
format as for individually added glycans: Monosaccharide(count) @ OGlycan or 
NGlycan | fine control option: 

 

Figure 28: Custom glycan entry format 
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Legacy Glycan DB file references can be converted into a list of custom glycans. When a glycan 
DB file and path are shown in the Glycan Processing node, click the “…” button to convert the 
reference to custom glycans: 

 

Figure 29: Converting glycan DB file reference to a glycan set 

Click Yes, and the contents of the glycan DB file are converted into custom glycans. If the glycan 
DB file is no longer in the path specified, an error message gives the option to clear the obsolete 
file path reference: 

 

Figure 30: Click Continue to clear an obsolete glycan DB file reference 

Click Continue and the Select Glycans dialog opens, cleared of the glycan DB file reference. 
Glycans can now be added using one of the methods described above. 

For some helpful examples and best practices for conducting N-linked and O-linked glycan 
searches, see our Application Notes at https://www.proteinmetrics.com/resources/. 

• Inclusion 

Inclusion is used to import a *.csv file which defines m/z ratio ranges and/or elution time range 
segments 

 

Figure 31: Inclusion option 

• MS/MS Filtering  

MS/MS Filtering creates MS/MS diagnostic peak filters.  

 

https://www.proteinmetrics.com/resources/
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Figure 32: MS/MS diagnostic peak filtering  

o The Peak Filters  button in Byos opens the Select Peaks dialog: 

 

Figure 33: Select Peaks dialog for MS/MS Filtering, with dropdown 

Click the drop-down arrow and select the diagnostic peak to filter. Alternatively, custom 
modifications can be entered manually in the box labeled Enter custom diagnostic peaks. 
The following is an example format of a diagnostic peak: Kdn / 251.076 

o m/z tolerance 

Set a maximum m/z tolerance value. Required Number sets a required count of diagnostic 
peaks to be applied from within the list. To set no minimum requirement, leave the value at 
zero. 

• S-S, Xlink (NOTE: This set of parameters is unique to the S-S disulfide analysis workflow.) 

  

  

Figure 34: S-S and Xlink parameters. 

This workflow allows the user to search for disulfide-bonded peptide pairs, trisulfide-bonded 
(also called persulfide-bonded) pairs, and more general cross-linking. This set of parameters 
also provides options to allow a user to search for expected and unexpected disulfide bonds. 
Enable S-S, Xlink analysis by setting Enable Disulfide parameter to “Yes”. Numerically 
designating which protein sequences from the FASTA database to consider in the For FASTA 
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Proteins parameter, an in-silico digestion will be completed based on the digestion parameters 
selected. The Xlink analysis considers every peptide that contains a cysteine and look to pair 
with other cysteine-containing peptides. The separation of numbers in the “For FASTA proteins” 
field below indicates how the potential pairings should be considered. For example, “1” searches 
for crosslinks in the first protein only. “4,5; 7” searches for all potential crosslinks on the 4th, 5th, 
and 7th protein, #4 and #5 may crosslink to each other, but not with #7. 

The Trisulfide option allows a user to search for trisulfides within a single peptide and 
linking 2 peptides. Similarly, the Crosslink: DSS and Crosslink: Custom allow a user to 
search for crosslinks within a single peptide and linking 2 peptides.  

The user can specify the modification fine control used in a custom crosslink search in the 
“Crosslink: Custom” text box.    

• Spectrum Input Options 

Spectrum Input Options help Byos cope with imperfect inputs. For example, on many MS 
instruments, precursor ion charges are uncertain for some or all spectra. 

 

Figure 35: Spectrum Input Options. 

o Apply Charges To - By default, the assigned charge will be used for all spectra with 
assigned charges and +1, +2, +3 will be used for all CID spectra and +2, +3, +4 for all ETD 
spectra without assigned charges. The Apply Charges To parameter allows the user to 
override this default setting by instead selecting unassigned spectra.  

o Charge States - All comma-separated charges detailed will be applied to each spectrum 
(based on the values entered into the Charge States box).  

o Precursor Isotope Off By X 

 

Figure 36: Precursor Isotope Off By X. 

Similarly, on many instruments the nominal precursor mass may actually be the mass of 
a 13C isotope peak rather than of the base (all 12C monoisotopic) peak, so the true 
precursor mass will within 10 ppm of 2350.120 Da or within 10 ppm of 2351.123 Da. 
Precursor Isotope Off By X is a pulldown menu with several options. 

No error check will use only the assigned precursor; Too high (narrow) will allow the 
assigned precursor to be up to 2 Da too high; Too high (wide) will allow the assigned 
precursor to be up to n Da too high for a precursor of mass at least 1000n Da; Too high 
or low (narrow) will allow the assigned precursor to be up to 2 Da too high or 2 Da too 
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low; Too high or low (wide) will allow the assigned precursor to be up to n Da too high 
or 2 Da too low for a precursor of mass at least 1000n Da. 

o Maximum Precursor Mass sets the Maximum Precursor Mass to be considered. 
o Precursor and Charge Assignments 

 

Figure 37: Precursor and Charge Assignments. 

The precursor and charge assignments will be calculated directly from the MS1 data or 
the originally assigned values will be applied. The user can set this using a drop-down 
menu. 

o Maximum Number of Precursors per Scan - Multiple precursors per scan can also be 
considered – it is recommended for the user to set this to 2 for complex samples and 5-10 if 
processing MSE or DIA data. 

o Smoothing Width - The user can enter a sigma value in Thomsons for Gaussian smoothing 
and centroiding of Waters or Sciex data. Half-width at peak half maximum (~0.01 m/z) works 
well and is the default value already entered for the user. 

• Peptide Output Options  

 

Figure 38: Peptide Output Options. 

The Peptide Output Options parameters offer options for filtering the peptide-spectrum 
matches (PSMs) by score. By default, PSM filtering is deferred until after protein ranking, and 
then filters to control PSM FDR on the “true” proteins—those ranked above the top-ranking 
decoy protein. This method gains sensitivity while simultaneously reducing both protein and 
PSM FDRs. See:  

Two-dimensional target decoy strategy for shotgun proteomics, Journal of Proteome Research 
10 (12), 5296-5301, 2011. 

o Automatic Score Cut - To filter PSMs before protein ranking, the user can click 
Yes to activate Automatic score cut and type in a minimum score.  

o Manual Score Cut - The user can activate Automatic Score Cut and enter a 
minimum score. For example, a score threshold of 200 will remove weak matches 
and a threshold of 400 will remove all but the best matches. Filtering by score may 
be helpful in special cases, for example to eliminate from consideration all but the 
best wildcard PSMs. 

o Show All N-Glycopeptides - The user also has the option to Show All N-
Glycopeptides. This will show N-Glycopeptide matches regardless of score or FDR. 
This is recommended for simple samples only. This can be especially useful for low 
energy CID data.  

 

• Protein Output Options  



Peptide Analysis Manual v5.12                                         

 

21 

 

 

Figure 39: Protein Output Options. 

o Protein FDR 

 

Figure 40: Protein FDR options 

This gives the user control of the protein list cut-off. By default, the protein list is cut at 
1% protein FDR or 20 decoy proteins, whichever comes last, but the user can ask for 
2% protein FDR or a completely unfiltered (but still ranked) protein list, or No Cuts.  

o Create a Focused Database - If the user clicks this to select Yes, the software is 
directed to output a new FASTA file (labeled focused and appearing in the output 
objs directory) containing only the proteins found in the search, along with suitable 
decoys (>Reverse) for unbiased FDR estimation. The focused database can then be 
used for subsequent wide searches, including more modifications and/or a wildcard. 
Of course, the user can also create focused databases outside of the software by 
editing existing FASTA files.  

o Export mzIdentML - The user can also select to export this file as a mzIdentML file.  

 

• Multicore Options 

 

Figure 41: Multicore processing options. 

The user can control the number of computer cores of the CPU used through the drop-
menu. The Light searches uses one core, Normal search uses all available cores minus 
two, and Heavy search uses all available cores.  

• Wildcard 

 

Figure 42: Wildcard parameters. 
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Figure 43: Wildcard Search drop-down menu options. 

Wildcard lets the user turn on wildcard searches, set the range for the wildcard mass, and 
restrict the wildcard to certain residues if desired. The options Disabled, Unmodified, and All 
peptides are available through a drop-down menu. 

The Restrict to residues box uses the common 20 single-letter residue abbreviations, and 
(lower case) n denotes peptide N-terminus and (lower case) c denotes peptide C-terminus (e.g. 
Kn searches lysine and N-terminus). Leaving the field blank searches fall residues. A wildcard, 
even one with a mass range of only 50 or 60 Da, greatly increases the size of the search. It is 
best used with a focused database (see the Advanced tab section below) and used either alone 
or with only a few other modifications enabled. Most wildcard mass shifts will be recognizable by 
an expert; hence, a wildcard can be used to discover which known modifications should be 
enabled in a subsequent search. For more details about the wildcard search, see the application 
note “Byonic™: Wildcard Search™” at https://www.proteinmetrics.com/resources/#application-
notes. 

By specifying most modifications as rare, it is quite feasible to search for 10 – 20 modification 
types at once with Byonic. Even larger searches are possible with focused protein databases, for 
example with therapeutic proteins. Such a focused database easily allows efficient mutation 
searches with 200+ possible substitutions, or oxidative footprinting searches with 50+ types of 
oxidations. Glycans and wildcards can easily enlarge the search space by 2 to 3 orders of 
magnitude, so these options should be used with care, and in conjunction with only the most 
common variable modifications (such as oxidized methionine or pyro-Glu N-terminus). NOTE: 
The single most important factor in search time is Total common max. Roughly speaking, the 
search time grows as CT where C is the number of common modifications enabled and T is Total 
common max.  

The Appendix of the Byonic Manual provides examples of frequently found modifications and 
appropriate syntax for including those modifications in a Byonic search. 

● Report 

 

An Excel workbook can now be generated from the Byonic workflows in Byos. To enable Excel 
report, the user should go to Processing nodes > Byonic column > Report and check the 
Enable Excel Report option. 

https://www.proteinmetrics.com/resources/#application-notes
https://www.proteinmetrics.com/resources/#application-notes
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Quant  

NOTE: As mentioned in the above MS/MS Ids section, these parameters apply alone to the PTM (in-silico) 
Workflow. 

• General 

 

Figure 44: Samples to include in the project. 

o Samples - The “*” will apply all parameters to all samples dragged and dropped into the 
Samples tab. 

• In-Silico Options  

 

Figure 45: In-silico options processing parameters. 

Parameters are separated into three sections to clarify which pertain to a Theoretical Digest, 
CSV import and both.  

o Enable In-Silico - The user has the option to click Yes to enable this parameter to generate 
an in-silico list of peptides. The below additional parameters must then be set. 

NOTE: The option to add a list of in-silico peptides from a CSV file is offered through In-
Silico Peptides CSV. 

o Disulfide mode (S-S workflow only) – restricts disulfide bonds to Free peptides only, 
Disulfide complexes only and Both: 

 

Figure 46: S-S Disulfide mode options 

o Digestion 
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Figure 47: Digestion options. 

The user can view several options through the drop-down menu. These are detailed as 
one letter residue codes adjacent to cleavage points. The user may enter a customized 
digestion by using the following syntax: Name @ Amino acid letters | C-term or N-term. 

o Missed Cleavages Max 

 

Figure 48: Missed Cleavages Max options. 

The user can set the maximum number of missed cleavages per peptide by selecting a value 
using the drop-down menu. A value of -1 allows any number of cleavages. 

o Peptide Minimum Mass - The user can set the minimum value of the peptide mass range. 
o Peptide Maximum Mass - The user can set the maximum value of the peptide mass range. 
o Total Common Max - The user can set the maximum number of common modifications per 

peptide. The search size grows by an order of magnitude with each increase in Total 
Common Max. 

o Total Rare Max - The user can set the maximum number of rare modifications per peptide. 
The search size grows by an order of magnitude with each increase in Total Rare Max. 

o Glycans - The user can specify glycan databsesor custom glycans to include in the in-silico 
generation. This is done the same as detailed in the MS/MS Ids section. 

o Modifications Options - The user can specify modifications to include in the in-silico 
generation. This is done the same as detailed in the MS/MS Ids section 

o In-Silico Peptides CSV - This option allows the user to to add a list of in-silico pepitdes 
from an imported CSV file, thus there is no need to run an MS2 search if there are known 
modifications with known masses and retention times. The format for the CSV is shown 
below. 
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Figure 49: Format for an In-Silico Peptides CSV. 

Skip if in-silico peptide is duplicate of MS2 - The user can click to select Yes. This will 
skip any generated in-silico peptide if one already exists from the MS2 data. It is 
recommended to make this selection when generating in-silico peptides. 

• MS extract options 

  

Figure 50: MS extract options. 

There are various aspects to the XIC of a peptide which can help in distinguishing a true from 
false identification, or whether the peptide hit is relevant based on intensity. 

o Relevant Peptides 

 

Figure 51: Relevant Peptide options. 

The user can select what types of peptides to consider relevant using the drop-down 
menu. Only peptides of interest will be considered for extracting additional information, 
such as XIC, isotope profile, and MS2 fragments. This pulldown menu option may affect 
the file size significantly. For SVA, the user may only need to choose Sequence variants 
and wildtypes. For peptide mapping, the user should choose All types. 
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o m/z integration window (ppm) - The user can define the maximum m/z error tolerance 
to be applied to the search. 

o Apex Search Window (minutes) - The user can automatically define the search 
window for the peak apex. 

o XIC Area Window (minutes) - The user can automatically set the time window for 
integration. The defined time limits will be visible as two vertical lines for each XIC in the 
project. These lines can be dragged by the user’s mouse to adjust the integration time if 
needed. 

 

• Isotope 

 

Figure 52: Isotope settings. 

The user can set the mass ranges for the offset from the monoisotopic mass. Click 
within the box to activate the light blue “…” button and view the default values. These 
values can be modified by typing in values. 

 

Figure 53: Isotope settings 

• Advanced 

  

Figure 54: Advanced options 

o Enable Lock-Mass Calibration - The user can click to select between No and Yes. 
o Lock Mass (m/z) 
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Figure 55: Lock mass m/z value options 

The user can enter the calibrant m/z value. Several are also available using the drop-
down menu or the user can type in a numerical value. If empty, no calibration will be 
applied.  

o Lock Mass tolerance (ppm) - The user can enter the calibrant m/z mass tolerance value in 
ppm. The user can type in a numerical value or use the up and down arrow keys to increase 
or decrease the value. If empty, no calibration will be applied. 

o Centroid Smoothing Width - The user can enter a sigma value in Thomsons for Gaussian 
smoothing and centroiding of Waters or Sciex data. Half-width at peak half maximum (~0.01 
m/z) works well and is the default value already entered for the user.  

o Elution Prediction Score Min - The user can set a value for this filter to find wildtype 
peptides with scores above this value to adjust the elution time.  

o Compute Fragment Coverage - The user can click between Yes and No to compute 
fragmentation coverage at project creation. 

o Advanced Configuration - The user can enter text commands to complete advanced 
procesing. These are detailed in the Release Notes included with each quarterly release. 
Please reach out to support@proteinmetrics.com for additional details.  

 

• Report 

 

Figure 56: Report Configuration Path 

Each Byos default workflow includes a report template created by our Customer Success team 
that is optimized for the specific type of analysis. If the user prefers a customized report 
template, they can direct Byos to this file using the light blue “…” button. They will be prompted 
to select a file. 

• UI Configurations 

 

Figure 57: UI Configurations – UI Column Filters and UI Layout 

The user can import column filters as well as layout files. This is designed to standardize 
analyses across all users, labs, and sites. The user can direct Byos to the preferred file for each 
using the light blue “…” button. The user will be prompted to select a file.  

• Feature Finder 

mailto:support@proteinmetrics.com
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Figure 58: Feature Finder 

Feature Finder is an algorithm that allows the user to scan the MS1 domain for all existent 
peptides in a sample. In a typical data dependent acquisition assay, peptides are identified only 
if an MS2 scan is triggered from a precursor ion in an MS1 scan. Therefore, if a peptide ion does 
not trigger an MS2 scan, or its score excludes it from identification, it will not be detected. 
Feature Finder ensures that a peak will not go undetected by identifying all possible isotopic 
distributions in a sample that could potentially be a peptide.  

Feature Finder also allows the user to match these features to the current identifications and to 
add a specified number of the unidentified features as unknowns to the project. Doing so will 
generate XICs for the unknowns and allow reporting on features such as retention time, mass, 
intensity, and fold change across samples. 

o Enable Feature Finder - The user can click to select between No and Yes to enable 
Feature Finder. 

o Minimum Isotope Corr. - The user can set the minimum cutoff to match the found isotopic 
distribution to the theoretical distribution using Pearson's correlation. If a feature has an 
isotopic distribution that is vastly different from its theoretical, this can be used to exclude it. 

o Mass Range Min - The user can set the minimum mass for a feature to be considered. 
o Mass Range Max - The user can set the maximum mass for a feature to be considered. 
o Maximum Features Count - The user can set the maximum feature count to include the 

most intense features. 
o Absolute minimum intensity - The user can set the minimum intensity for a feature to be 

considered. 
o Minimum Isotope Count - The user can set the minimum number of isotope peaks required 

for a feature to be considered. This applies only if its charge is greater than 2. 
o Minimum Peak Width (min) - The user can set the minimum peak width in minutes for a 

feature to be considered. 
o Minimum S/N Ratio - The user can set the minimum S/N ratio for a feature to be 

considered. 
o Minimum Scan Count - The user can set the minimum scans required across the peak for 

a feature to be considered. 
o Exclude +1 Charge Only Features - The user can click to select between Yes and No to 

exclude singly charged features. 
o Exclude Features With MS2 Matches - The user can click to select between No and Yes 

to exclude features with MS2 matches. Exclude will remove the feature if it coincides within 
the time and mass tolerances set – it will not be included in the top X features to avoid 
duplicates. It is recommended to check this box for projects containing MS2 data and Byonic 
searches. 
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o Mass matching tolerance (ppm) and Time matching tolerance (min) - These parameters 
are used to match and remove features that have already been identified by MS2 (when 
Exclude Features With MS2 Matches is set to Yes) so that they do not contribute to the 
maximum feature count. They help to match the retention time and mass of an unknown 
feature to a MS2 feature so that it may be excluded from the Peptides table in Peptide 
Analysis. 

• XIC 

XIC refers to the “Extracted Ion Chromatogram”, which represents the signal intensity of an ion or 
ions of interest over time extracted from the full mass spectrometry dataset. Fast XIC accelerates 
XIC processing. As of Byos v5.9, Fast XIC will be enabled during workflow updates if the feature is 
not yet enabled.   

 

Figure 59: Fast XIC parameters 

If Enable Fast XIC is set to Yes, the below options are available: 

Parameter Description 

Granularity Integer value, relating to the precision. 10000 is 4 places past 
the decimal.  For mass 1000.1236, a granularity of 1000 sets the 
value to 1000.124, while a granularity of 10000 keeps the value 
at 1000.1236. Default value is 100000. 

Max Mz Integer value. The maximum m/z value during data acquisition. 
To acquire data in the range 200-2000, set Max Mz = 2000, so 
that no ions are acquired past that value. Default value is 3010 

Max Ion Count Integer value. The maximum number of ions to be considered, 
sorted by intensity. Some files may contain ~2500 ions per scan. 
Max Ion Count = 1000 uses only the top 1000 ions by intensity. 
This is especially important for TOFs with ~25K ions per scan, 
where a higher value of 2500is recommended. Default value is 
3000. 

 

Main Menu Bar 

The topmost menu bar includes four items: File, Edit, Window, Server, and Help. 

File Menu 

The File pull-down menus manage project files and export reports and data: 
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Figure 60: File menu (Standalone and Byosphere Client) 

The File menus include items to create new projects, open previously created projects from saved files, 
save a copy of an open project, close a project (yet leave the application open), and exit Byos. Mouse 
over the Recent Projects menu to open a side window with a list of recently visited projects that can be 
reopened. 

The File menu functions New Project, Open Project, Retrieve missing resources, Close Project, Label 
Manager and Report, respectively, are also available as icon buttons below the topmost menu bar: 

  

Figure 61: File menu icons 

File > Export Menu 

There are also three File sub-menu items to export reports. 

  

Figure 62: File > Export menu 

File > Export > Report generates a report that includes a summary of the project files, one or more pivot 
tables (that can be visualized as bar charts, etc.), along with plot images. There are other valuable tools 
for making customizable reports and regulatory filing documents. When a report is perfected, a copy of 
the report configuration can be saved to use with other reports. If no report configuration is attached to the 
project, a default report configuration is used to generate the report.  
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Figure 63: Default report format 

To replace the report with another report template, choose in the report window File > Presets > Report 
presets > <template name>: 

 

Figure 64: Changing the report template in a created report 

File > Export > Generate Multi-document report opens a dialog into which the user drags and drops 
multiple Byos Peptide project *.blgc files:  
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Figure 65: Multi-document report export 

File > Export > Generate MS path template CSV … 

To learn about reports in detail see the document PMI Reporting Manual.pdf. Contact 
support@proteinmetrics.com for information on a variety of existing and new report templates. 

Edit Menu 

The Edit pull-down menu manages program settings. 

mailto:support@proteinmetrics.com
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Figure 66: Edit menu 

Undo and Redo allow the user to undo or redo changes. These Edit menu functions are also available as 
the arrow toolbar buttons below the menu bar to the right of the Help menu. 

The Label Manager is used to add, remove and edit label values. These labels can then be assigned to 
records in the Peptides table. To add a new label, click the Add button, enter the label text, and click OK. 
To add or edit a comment to a new or existing label, select the label in the Label Manager view, and edit 
the comment in the Edit comment view. To edit a label, select it, click Edit, edit the label text, and click 
OK. To remove a label, select it, click Remove. Click OK in the main window to save all changes.   
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Figure 67: Label manager 

To add or remove labels to a record in the Peptides table, click the peptide row, scroll to the Labels 
column, click the cell in this column to open a dialog. Check or uncheck desired labels and click OK. The 
Label Manager can be opened from this dialog by a click on the Manager button. 

 

Figure 68: Adding labels in the Peptides table 

The Search Filter filters records displayed in the Peptides table according to a variety of properties and 
categories. Edit values for properties to tighten or loosen restrictions. Check additional Show categories 
to include peptides that are not true positives. Click the Peptide grouping method drop-down arrow to 
combine peptides that differ only by their charge states.   
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Figure 69: Peptide search filter 

The Peptide type filter tab allows the inclusion or exclusion of peptide modification types. Check 
modifications to include and uncheck modifications to exclude. Byos defaults to all peptide types: 
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Figure 70: Filtering by peptide type 

To save the edited settings from the two tabs to a configuration file, click the Save Preset button, enter a 
file name, navigate to a directory, and click Save. To load settings from a previously-saved configuration 
file, click the Load Preset button, navigate to the desired directory, select a *.blgcsfson or *.blgcsf file, and 
click Open. 

Show undetected digest peptides in report allows for either including or excluding the undetected 
peptides for reporting. Enabling this setting will result in a new label “ND” in the Comment column in 
reporting tabs, denoting that the specific peptide is not detected in the analyses. 

Attach report configuration attaches a report configuration file to the project, to be used instead of the 
default report configuration. Report configuration files (graphical layouts) are generated from File > Export 
> Report and have the extension *.rptc. This menu can also be used to remove an attached report 
configuration file. 

Attach report configuration attaches a report configuration file to the project to be used in place of the 
default report configuration. Report configuration files (graphical layouts) are generated from the project 
report opened using File > Export > Report, and then saved using File > Save to file. Configuration have 
the extensions *.rptc, *.tabc, *.lvcfg, or *.pvtcfg. This menu can also be used to remove an attached report 
configuration file. 
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In-silico Peptides contains five sub-menus to import or export in-silico peptide candidates before or after 
project creation: 

 

Figure 71: Edit > In-silico Peptides menu 

● Add In -silico Peptides From CSV File opens a browser to load a *.csv file of in-silico 
candidates. Use of the correct format for the *.csv file is required. For an example of the correct 

*.csv format, see the file ImportExample.Byologic.csv in Program 
Files\ProteinMetrics\PMI-Suite\ExampleData. 

● Add Missing Via Existing Peptides identifies missing peptide sequences and fills in those 
sequences from equivalent peptides in the sample files. Support has been added in v5.10 of 
Byos allowing users the option to apply advanced sample-to-sample XIC alignment and peak 
detection to newly added peptides or not. 

● Export In -silico to CSV exports the in-silico peptides to a *.csv file. This peptide file is then 
available for import into a different project. Enter a file name, navigate to a directory, and click 
Save. 

● Export Theoretical Digest list to CSV exports the theoretical digest information directly to a 
*.csv file. This file is then available for import into a different project. Enter a file name, navigate 
to a directory, and click Save. Note that to be able to export theoretical digest in-silico, it must be 
enabled during Project Creation.  

● Peptide Manager combines all of the In-silico functionalities from Edit > In-silico peptides with 
a color-coded preview of the project changes and enhanced control over which rows and 
columns are affected. 

 

Figure 72: Peptide manager 

The user can set which columns are editable using the drop-down menu. 
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Figure 73: Editable columns in Peptide manager 

o Export CSV is the same as Edit > In-Silico > Export CSV.  

Start and End times may differ from the previous CSV export. This is because Peptide Manager 
exports the most centered XIC start/end, while the old method exported the first 
available start/end range. The difference is considered an improvement.  

o Import CSV is the same as in Edit > Import in silico from CSV 

o Intersect CSV replaces the old menu item Edit > In-Silico > Intersect with CSV 
library. This menu item has been removed and can only be accessed from Peptide 
Manager.  

 

Figure 74: Intersect CSV: import with CSV library dialog 

Select a CSV file using the Browse button. Matching options include Use mass and time and Use 
sequence and modifications. Set mass and time tolerances. Check Append 
unmatched to include non-intersected peptides. Click OK to return to Peptide Manager 
and select columns to review. New values will be show in red.  
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Figure 75: Peptides imported from CSV library are marked in red 

Expanded rows to showcase additional content: 

 

 

Figure 76: Imported peptides, expanded 

o Add missing samples is the same as in Edit > In-Silico > Add missing. 

Click the button and then Apply to update the project with new in-silico peptides. These will be visible 
at the end of the list.  

 

Figure 77: Peptide manager after using Add missing samples 

Click Apply to update the project. The figure below displays a common use case: Feature Finder 
unknowns matched with in-silico content. 
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Figure 78: Peptides added with Add missing samples 

● The Audit Trail documents all change made through the Peptide Manager, including 

o The CSV intersected 

o The columns altered 

o How many peptides were affected 

 

Figure 79: Audit Trail after using Peptide manager 

Feature finder opens a dialog which includes the settings available in the Feature Finder tab during 
project creation: 
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Figure 80: Feature finder dialog 

Add MS File(s) imports additional MS files after project creation. The MS files have extensions *.d, *.raw, 
*.wiff, *.lcd, and *.byspec2. Navigate to the desired file and click Open.  

Enable Deamidation Quantification recalculates XIC integrations to account for the interference 
between a deamidated peptide and a wildtype peptide with a similar isotope value. The wildtype integration 
is subtracted from the total to yield a “pure deamidated” XIC plot. 
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Figure 81: Deamidation quantification subtracts the wildtype integration from the total 

Protein Annotations is used to annotate individual proteins for display in the Peptides table: 

 

Figure 82: Protein Annotations 

To annotate a protein, select it in the Proteins window, click Add row, specify the starting amino acid and 
sequence length, and then enter text under Annotation value in the Protein Annotations window. The 
Find antibody CDR’s button finds antibody complementarity determining regions and displays them in 
the Protein Annotation column of the Peptides table. Click Close when finished. 

Show Byos project creation options displays the workflow project creation options used to generate the 
project.  
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Figure 83: Show Byos project creation options 

The Sequences and Processing nodes tabs open to show all the entries used in those tabs. 

Show project creation options is obsolete and can be ignored. 

The Advanced configuration dialog is used to enter text commands, which are often new features still in 
beta testing. A list of available advanced commands can be found here.  

Adjust colors is used to modify the default colors associated with MS samples and corresponding plots. 

Adjust MS paths is used to modify the path to the source MS file, should the file be moved. Enter or 
navigate to the new directory containing the MS file. 

  

Figure 84: Editing the MS file path 

Edit PDB loads protein database files for use by Protein 3D reports. 
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Window Menu 

The Window pull-down menu manages the visual layout of the user interface, and the arrangement and 
sizes of the various table and plot views: 

  

Figure 85: Window menu 

Load Layout opens a saved layout stored to files with extension *.ini. Save Layout saves the current 
layout to an *.ini file, which can be used in other projects or shared with other users. Restore Default 
Layout applies the layout used when the application is first opened. 

The current layout can be customized by moving, resizing, or editing the view panes. Many of the views 
(Project, Protein coverage, XIC, MS2 and mass error, and Isotope plots) can be undocked by double-
clicking on the tops of that view to create standalone windows that can be moved to another monitor. 
These views can be click-dragged to new locations in the layout. The view can also be resized by hovering 
over the vertical or horizontal edges between table and plot views so that the cursor changes to arrows: 

 or . Left click and drag the edges up or down or right or left to change the sizes of the views. 
Columns in the table views can be made larger or smaller in same manner. To reorder columns in a table, 
left click the name of the column, and drag it to the new location. To do a simple sort, left click the header 
once to sort ascending and twice to sort descending. Mouse over a column header to see a description of 
that field. 

Column headers can be modified through the Column Header Editor dialog, opened by a right-click 
anywhere on a table column header. 
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Figure 86: Column Header Editor 

Columns can be rearranged by dragging the header names up or down. To hide a column, uncheck the 
Visible box for that column. This dialog can also be used to specify number of significant figures and 
ranked sorting. The Window > Save Layout menu preserves these edits for future use and sharing. The 
Reset row sorting and Reset column order buttons restore the default row and column properties. 

The Search Box can be used to search for specific values or variables, with options to filter for only whole 
values, with case-sensitivity, and to only search in vertical header columns. 

 

Figure 87: Search box filters 

A selected row can be moved to the top or the bottom by clicking Move to bottom or Move to top; 
alternatively, the same actions can be performed by pressing Alt + t or Alt + b, respectively.  

Enable Stacked Plots can be turned on to separate the plot view into a series of normalized traces of all 
the sample data: 
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Figure 88: Example of stacked isotope plots 

Turning on Enable Stacked Plots - Overlay Charge States functions the same as Window > Enable 
Stacked Plots, except for in the XIC plot widget where XICs with different charge states will be overlayed 
within the same sample. Users must ensure that charge states are combined prior to selecting this option. 

Hide Wildtype removes the wildtype peptide records in the Wildtype peptides table and the 
corresponding wildtype peptide plots in the XIC plots, MS2 and mass error plots and Isotope plots: 

 

Figure 89: Example of hidden wildtype plot 

The Show Wildtype menu displays the Wildtype peptide table records and wildtype plots again. 

Show Chromatogram XIC Plot opens an undocked window displaying chromatograms for the projects. 
The traces are displayed in the colors of the samples they represent:   
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Figure 90: Undocked Chromatogram XIC plot 

Server Menu 

Currently Server > Configure is supported for the Waters UNIFI server. See the PMI UNIFI Integration 
User Guide for instructions on how to configure UNIFI integration. 

 

 

Figure 91: Server menu 

Help Menu 

The Help pull-down menu provides information about the software: 

 

Figure 92: Help menu 
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The About menu shows the software version number, which is needed when reporting issues. The Log 
menu opens a log containing recent activity; this is helpful for troubleshooting problems together with 
Protein Metrics, Inc. staff via support@proteinmetrics.com. Support Package opens a dialog to generate 
a comprehensive set of files to better enable Protein Metrics to troubleshoot problems. Click Review & 
edit the package to generate a directory of individual files as directed. Click Compress to generate a zip 
file of this support directory. An information box indicates where the zip file can be found and gives a link 
for support@proteinmetrics.com.  Open User Guides opens the installed folder with the manuals and 
quick start guides for all Byos workflows. Check For Updates will report if an online update is available 
for installation. Online Resources opens the Protein Metrics, Inc. Secure Resources webpage containing 
a variety of technical pages and tutorials related to Protein Metrics, Inc. software. Register is used to 
activate the software upon first use. 

Table Menus 

The menu bars at the top of the three table views (Project, Peaks, and Candidates) share icons that 
manage hierarchical lists and filter on data. 

● The  icon expands rows to show “sub-rows”. 

● The  icon collapses rows to hide sub-rows. The use of sub-row depends on the table. For 
example, in the Peptides table, a row is a peptide record and a sub-row is the data resulting 
from an individual sample that contained the peptide. 

● The  icon exports the table to a *.csv file for opening with Excel. 

● The  icon opens a dialog to create custom filters for that data table. (A single column filter can 
also be set by right-clicking on an entry in the column.) Select a column in the first cell, select an 
operator in the second cell, and enter text in the third cell. A second filter row becomes available 
for further entry. Click the red X after a filter row to delete it. Custom filters allow masses to be 
filtered by mass range, annotation, intensity, and so forth. Custom filters can be stored with the 
project document or exported and imported using the Presets dropdown. 

● The  cell filters the entered text across the content of all columns in the protein 
and peptide tables. The records are filtered automatically as text is entered. Click the  icon to 
search the string as a whole word or as case sensitive. 

● To sort the contents of a column by ascending value, click the column header. Click the column 
header again to sort by descending value. 

Table Right-Click Menus 

The Project, Protein Coverage, Peptides, and Wildtype peptides tables have context menu items revealed 
by a right-click on the rows within the tables. (Recall that a right-click on the header of these tables opens 
the Column Header Editor dialog.) 

 

Figure 93: Table right-click menus 

● Export table to CSV saves the table content and headers to a *.csv file using parameters 
chosen in the Export data dialog. 

mailto:support@proteinmetrics.com
mailto:support@proteinmetrics.com
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● Copy selected row(s) to clipboard copies selected table rows, with their headers to be 
available for pasting into another application. (This menu is not available in the Protein Coverage 
table.) 

● Copy selected cell to clipboard allows the user to copy the contents of the selected cell. It 
works just like CTRL+C. 

● Table context menus contain a set of query options for searching the clicked text value using 
any of the available search operators. This is an easy way to filter a table based on a specific 
field value. 

 

Figure 94: Search table values through a right-click menu 

Project Table 

The Project table contains information about the MS samples and results files: 

 

Figure 95: Project table 

To display or remove the MS sample and result combination, check or uncheck the box at left of either a 
sample or result record. To edit a MS sample or result alias name, right-click the entry to edit under the 
Alias Name header, click Edit selected row(s), edit the name, and then click OK. 
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Protein Coverage Table and Menu 

The Protein Coverage table displays peptide sequences and corresponding protein coverage. The 
accompanying display maps the protein sequences of detected peptides to colored lines below each 
sequence representing colors assigned to different MS samples: 

 

Figure 96: Protein Coverage table 

The different colors within the colored bars indicate the presence of peptide modifications at those 
positions. (The colors used are chosen for contrast and do not reflect the colors assigned to the MS sample 
files.) 

The Protein Coverage table also includes the following specialized menu icon buttons: 

● The  icon opens the Protein coverage rendering options dialog: 

 

Figure 97: Protein coverage rendering options 
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● The  icon turns on and off the display of the tabular protein coverage data. 

The Protein Coverage view has context menu items revealed by a right-click on the graphical portion of 
the display: 

 

Figure 98: Protein Coverage right-click menu 

● Rendering options also opens the Protein coverage rendering options dialog shown above. 

● Export coverage creates a *.png file of the graphical protein coverage display. 

● Export to FASTA creates a *.fasta file of the proteins found in the Protein Coverage view. The 
*.fasta file is then available to be imported into new projects. 

Peptides Table and Menu 

The Peptides table contains detailed information about all identified peptides: 

 

Figure 99: Peptides table 

The Peptide table organizes records in the following hierarchy: Peptide > Sample > Charge state (if 
combined) > MS2 scan. Records in the Peptide table can be modified directly by the user for three fields: 
Validate, Comment, and Labels. In the Validate field, the user selects between “True-positive”, “False-
positive”, and “Uncertain”. Comments are input directly. Values for Labels are selected from a list. To 
create new labels to use in the Labels field, see Edit > Label Manager. 

Note: The MS1 correlation score compares the measured MS1 isotope distribution to the theoretical 
distribution calculated using cosine similarity. A score of 1 is a perfect match. 

In addition to the usual table menu buttons, the Peptides table contains the  icon button which opens 
the same Search Filter dialog that is opened by the Edit > Search Filter menu. The text filter entry box 
allows the records to be filtered based on the occurrence of the given text string searched across all fields. 

The Peptides table has context menu items applicable to specific peptides. The menu is revealed by a 
right-click on a peptide cell in the table: 
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Figure 100: Peptides table right-click menus 

● Show/Edit alternatives displays a table of alternative MS2 identifications (with different sequences 
and/or modifications) for the selected peptide, along with their scores: 

 

Figure 101: Peptide alternatives table 

Select an alternative peptide and click Replace to replace the selected peptide in the Peptides table. 
Protein coverage, observed and calculated masses and m/z ratios all are updated. 

● Show protein summary opens a table with protein data for that peptide: 

  

Figure 102: Protein summary 
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The values in the Protein summary can be captured in a report using the template 
Blgc_PRM_wProteinDuplicates.rptc. 

● Show alternative glycan structures… allows the user to access alternative glycan structures 
rendered for glycopeptide modifications in generated reports featuring glycan cartoons. The 
table provides associated structures currently in the backend library. Users can also select Add 
new structure from IUPAC…to enter a new glycan structure to add to the library. See the PMI 
Chromatogram Analysis Manual for more information about building alternative glycan 
structures from IUPAC. 

 

Figure 103: Show alternative glycan structures 

 

  

Figure 103:Glycan Structure Selection 

● Set XIC time interval allows the user to edit the XIC start and end times for that peptide and to 
set the time tolerance (time warp) to improve performance: 
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Figure 104: Set XIC time interval 

● Create new peptide from current makes a copy of that peptide. This allows XIC plots to be 
split according to separate integrations. The user edits the start and end times and the charge of 
the peptide before the copy is created: 

  

Figure 105: Create new peptide from current 

● Edit proposed XIC splits opens a dialog to enter pairs of time ranges to split XIC plots for that 
peptide record into two or more chromatograms: 

  

Figure 106: Edit proposed XIC splits 

After a click on the OK button, the Peptides table record field XIC proposals is updated with the time 
range entries. The split must be applied to take effect. 

● Apply proposed XIC splits separates a record in the Peptides table into two or more records 
using the time ranges entered using the Edit proposed XIC splits function.  

● Add to XIC overlay adds the selected Peptides table record (subject to the right-click) or 
collection of records as an overlay to the XIC plots view mapped to the same time axis: 
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Figure 107: Add to XIC overlay 

When this function is applied to a collection of records in the table, all of the records below it are added 
to the XIC plots view. 

● Remove from XIC overlay removes the overlay from the selected Peptides table record 
(subject to the right-click) from the XIC plots view. 

● Clear overlays removes all sample overlays from the XIC plots view. 

Wildtype Peptides Table and Menu 

The Wildtype peptides table contains detailed information about naturally occurring or wildtype peptides 
associated with the peptide selected in the Peptides table: 

 

Figure 108: Wildtype Peptides table 

The Wildtype peptides table has one context menu item specific to wildtype peptides. The menu is 
revealed by a right-click on a wildtype peptide cell in the table. Set primary wildtype marks that record 
as the primary wildtype peptide for the selected record in the Peptides table. 

Validators 

Additional validation is an essential step of degradant and sequence variants analysis. The SVA report, 
provided as a preset and used as the default report in the SVA workflow, contains a column for auto-
validation called “SV auto-comment.” These are now also available in the inspection view. The following 
two sets of advanced commands enable the user to complete validation through comments automatically 
populated in the Peptides table, as shown below. 
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Figure 109: Peptide table Comments apply the Mod and SVA Validators 

Mod Validator  

Allows a user to assess the validity of a degradation analysis automatically.  When this feature is activated, 
the algorithm will iterate row by row and assess whether the modification meets or fails certain thresholds 
(as explained below). Please note that this algorithm does not assess sequence variants. The SVA 
Validator algorithm is specifically designed for sequence variants (detailed directly after this). 

The feature can be activated in the Advanced configuration section in Peptide Analysis/Byos with the 
following advanced commands: 

[Byologic] 

ModValEnabled = true; 

 

 

Threshold parameters that can be modulated are as follows (with default settings): 

[ModValidatorOptions] 

DeltaModScoreThreshold = 10.0; 

ScoreThreshold = 225.0; 

FwhmThreshold = -1;  

IntensityRecoveryPercentileThreshold = 0.05; 

 

 

Mod Validator Option Parameter Description 

DeltaModScoreThreshold The acceptable threshold of the delta mod score. If a 
degradation score falls below the set threshold, a warning 
is added to the Comments field to alert the user. 

ScoreThreshold Same as deltaModScoreThreshold except it will alert if a 
Score is below the threshold. 

FwhmThreshold The FWHM is used as the minimum retention time 
difference that categorizes a modification as coeluting 
with its wildtype. A setting of -1 determines the average 
FWHM of the input files and then automatically calculates 
the threshold. To set this manually, use any real number 
greater than 0. For example, if this is set to 0.05, this 
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means that if a degradation has a retention time 
difference from its wildtype of less than 0.05 minutes, the 
user will be alerted in the Comments field. 

IntensityRecoveryPercentileThreshold This will alert the user if the apex intensity of the 
degradation lies within the bottom x percentile. For 
example, if this is set to 0.05, then whenever the intensity 
of a peak is in the bottom 5%, a warning will be added to 
the Comments field. 

 

The Comments field in the Peptide window will be filled out for various rows.  Please note that this field 
sorts with no comments first, so the user may have to scroll to the end of the peptide window to find the 
labels.  

Starting with v. 3.10, the Mod Validator no longer treats pyroGlu (pyrolization of N-terminal glu/gln) as 

a sequence variant. 

SVA Validator  

Allows a user to assess the validity of sequence variants automatically. When this feature is activated, the 
algorithm will iterate row by row and assess whether the sequence variant meets or fails certain thresholds 
as explained below. 

Reference: Zhongqi Zhang, et al, Biochemistry, 2013, 52, 45, 8165-8176. 

The feature can be activated in the Advanced configuration section in Peptide Analysis/Byos with the 
following advanced commands: 

[Byologic] 

SvaEnabled = true; 

 

 
Threshold parameters that can be modulated are as follows (with default settings): 

[SvaOptions] 

DeltaModScoreThreshold = 10.0; 

PercentXICRatioThreshold = 1.0; 

ScoreThreshold = 225.0; 

FwhmThreshold = -1; 

PredictedTimeDiffThreshold = 5.0; 

CommonModLookBothWaysFromModResidue = 3 

 

 

SVA Validator Option Parameter Description 

DeltaModScoreThreshold See Mod Validator above 

PercentXICRatioThreshold The acceptable threshold of the XIC Percentage Ratio. If the 
ratio falls below the set threshold, a warning is added to the 
Comments field. Depending on how the *.rptc file is configured, 
the XIC Ratio % value may not match the quantification in the 
reports since the reports allow multiple kinds of quantifications 
(one charge state, multiple charge states, etc.). 

ScoreThreshold See Mod Validator above 

FwhmThreshold The FWHM is used as the minimum retention time difference 
that categorizes a modification as not co-eluting with its 
wildtype.  

https://pubs.acs.org/doi/10.1021/bi401002c
https://pubs.acs.org/doi/10.1021/bi401002c
https://pubs.acs.org/doi/10.1021/bi401002c
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A setting of -1 determines the average FWHM * 2 of the input 
files and then automatically calculates the threshold. This is the 
recommended setting for this parameter (feedback is 
welcomed).  

However, this can be manually set to any positive value (this is 
not recommended). 

PredictedTimeDiffThreshold This threshold alerts the user if the predicted retention time in 
minutes for the sequence variant exceeds the set threshold. A 
“Critical” label is displayed in the Comments field. 

CommonModLookBothWaysFromMo
dResidue 

The count of residues on either side of the putative site of a 
sequence variance to search across for a more common 
modification that better explains the results.  

For example, consider the wildtype peptide AAVLAMK, when 
this parameter is set to 3.  

Then, a putative sequence variant of AAdLAMK (V->D) is 
proposed with a delta modification of ~16 Daltons.  

The program searches the 3 amino acid residues to the left and 
3 to the right of this site for a more common modification (such 
as methionine oxidation) with the +16 Da shift.  

In this case, there is a methionine residue 3 residues to the right 
of the putative sequence variant, so a “Warning” label is 
displayed in the Comments field. 

 
Now the Comments field in the Peptide window will be filled out for various rows. Please note that this field 
sorts with no comments first, so the user may have to scroll to the end of the peptide window to find the 
labels.  

● Filtering – “Var. Pos. Protein” and “Var. Pos. Peptide”  

The values in "Var. Pos. Protein" and "Var. Pos. Peptide" columns during filtering are treated as a list of 
integers. For these columns only the list of integers (integers separated by a comma) is 
acceptable when entering filter conditions in the dialog. 

 

Figure 110: Filter by Var. Pos. Protein and Peptide 

If a non-integer value is entered, the user will receive an error message to correct the value entered, as 
shown below. 
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Figure 111: Var. Pos filtering requires integers 

Wildtype Validator  

The Wildtype Validator quickly scans wildtype PQMs for scoring violation. To use the Wildtype Validator, 
enter the following code in Advanced Commands: 

[Byologic] 

WildTypeValEnabled = true; 

 

 

Threshold parameters that can be modulated are as follows (with default settings): 

[WildTypeValidatorOptions] 

ScoreThreshold = 225.0; 

IntensityRecoveryPercentileThreshold = 0.05; 

PPMStandardDeviations = 3 

 

 

Wildtype Validator Option Parameter Description 

ScoreThreshold See Mod Validator above 

IntensityRecoveryPercentileThreshold This will alert the user if the apex intensity of the degradation 
lies within the bottom x percentile. For example, if this is set 
to 0.05, then whenever the intensity of a peak is in the bottom 
5%, a warning will be added to the Comments field. 

PPMStandardDeviations The number of standard deviations (square-root of the 
variance) in ppm for a result to be considered 

Disulfide Validator  

The Disulfide Validator analyzes disulfides similar to how the SVA Validator analyzes sequence variants 
and the Mod Validator analyzes degradations. Peptide analysis by the Disulfide Validator populates the 
Comments column. The following two sets of advanced commands enable the user to complete validation 
through comments automatically populated in the Peptides table, as shown below: 

[Byologic] 

DisulfideValEnabled=true; 

 

 
Threshold parameters that can be modulated are as follows (with default settings): 
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[DisulfideValidatorOptions] 

DeltaModScoreThreshold=10.0; 

ScoreThreshold = 150.0; 

FwhmThreshold = -1; 

MS1Correlation = 0.8; 

IntensityRecoveryPercentileThreshold = 0.05; 

PPMStandardDeviations = 3 

HingeDeltaModScoreThreshold = 10.0; 

HingeScoreThreshold = 150.0 

 

 

Disulfide Validator Option Parameter Description 

DeltaModScoreThreshold See Mod Validator above 

ScoreThreshold See Mod Validator above 

FwhmThreshold The minimum retention time difference that categorizes a 
modification as not co-eluting with its wildtype. A setting of -1 
determines the average FWHM of the input files and then 
automatically calculates the threshold. To set this manually, 
use any real number greater than 0. For example, if this is set 
to 0.05, then a degradation has a retention time difference 
from its wildtype of more than 0.05 minutes and the user will 
be alerted in the Comments field. 

MS1Correlation The minimum isotope distribution match needed for a result to 
be considered. 

IntensityRecoveryPercentileThreshold This will alert the user if the apex intensity of the degradation 
lies within the bottom x percentile. For example, if this is set 
to 0.05, then whenever the intensity of a peak is in the bottom 
5%, a warning will be added to the Comments field. 

PPMStandardDeviations The number of standard deviations (square-root of the 
variance) in ppm for a result to be considered 

HingeDeltaModScoreThreshold The acceptable threshold of the delta mod score for a 
monoclonal antibody. If a degradation score falls below the 
set threshold, a warning is added to the Comments field to 
alert the user. 

HingeScoreThreshold Same as HingedeltaModScoreThreshold, except it will alert 
the user if a Score is below the threshold. 

 

● The Disulfide Validator will operate on disulfide and trisulfide peptides, but the Mod Validator can 
also operate on disulfides and trisulfide peptides as well.  Sequence variants will not operate w/ Mod 
Validator and vice versa. 

● Users do not activate MS1 Correlation in the advanced settings.  The code will apply this if it is set 
but will bypass it if it is not. 

● PPM errors are normally distributed.  This allows for usage of standard deviations from mean as a 
generalized and robust metric that is empirically derived from the data analyzed rather than 
ostensible vendor specifications. 

● The validator also checks for ambiguous assignments, i.e., if a peptide sequence in the disulfide is 
found in multiple places within the protein, a flag will be added in the Comments field. 
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Source Dissociation Validator  

A validator was implemented to identify PSMs that are products of in-source dissociation. An identification 
is labelled as such in the comments column if it shares the same elution profile with another identification 
or feature with higher mass. The comment provides the PID and mass difference of the precursor from 
which the source dissociation product originates. To enable the validator in the Advanced tab, add the 
following in the Advanced Configuration section: 

[Byologic] 

SourceDissociationValEnabled =true; 

 

As of Byos v5.4, this advanced command will also add a comment to any feature that coelutes with its 
wildtype peptide. This varies from the previous behavior, which requires the source artifact to have lesser 
mass than the attributed parent ID. 

Plot Menus  

The menu bars at the top or sides of the three plot views, XIC, Isotope, and MS2 and mass error, share 
icons that support generic operations on plots. These icons appear in almost all Protein Metrics, Inc. 
software products. 

● The  icon resets the plot to default zoom level. Shortcut = double left-click. 

● The  icon enables zooming in. The cursor changes to this icon. Drag across the range of the 
plot to display to zoom to that x-range. By default, the plot’s y-range scales according to the 
maximum y-value within the x-range, but the software also supports freeform zooming as 

enabled under the  icon. 

● The  icon enables zooming out. Click anywhere in the plot to zoom out. 

● The  icon enables moving (panning) across the plot. The cursor changes to this icon. Click 
the plot and drag up or down, right or left to view a part of the plot that is off-screen. 

● The  icon locks the x-axis for stacked plots in a plot view to use the same ranges. Unselecting 
this allows stacked plots to apply independent x-axis ranges. 

● The  icon performs an undo of the last zoom step. Shortcut = Shift-left arrow key. 

● The  icon performs a redo of the last zoom step. Shortcut = Shift-right arrow key. 

● The  icon manages how plots are displayed (render options), as well as zoom modes. The 
Render and zoom options include: 
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Figure 112: Render and zoom options 

o Show x values and Show y values display the x- or y-coordinates beside plot peaks to 
the chosen number of significant figures. 

o Show delta: when checked, displays the x or y differences from a reference peak when 
the cursor hovers over a peak tip. 

o Show centroided peaks darkens the peak positions that are determined to be 
centroided. 

o Show plot title displays the title of the plot, as generated from field values. 

o Label orientation, when checked, orients labels to some angle other than horizontal. 

o Show XIC proposals (XIC only) displays the proposed XIC plot splits generated by the 
Edit proposed XIC splits context menu in the Peptides table. The plot splitting is 
represented graphically as gray rectangles showing the edited integration limits: 
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Figure 113: Edit proposed XIC splits 

The Zoom and pan mode options include: 

o Match x-range, when checked and followed by reset zoom (click on the  icon) the 
peptide and wildtype peptide plots are redrawn using the same x-axis values. 

o Free form mode to manually select the desired y range as well as x range. 

o Auto scale mode to select only the x range (the y range is then adjusted to the value of 
the highest peak).  

o Locked view mode to keep the current x range (for either m/z and/or m) when moving 
between elution peaks. 

o Locked x-axis mode turns off autoscaling for the x-axis (but not the y-axis) and applies 
the current x-axis scale across all Peptide table selections. 

Under Scrolling, the Visibility setting controls display of the scroll bars:  

o Always on displays scroll bars even when the full plot is shown. 

o Always off turns off display of the scroll bars even when a partial plot is shown. 

o Show as needed displays scroll bars only when a partial plot is shown. 

Plot Right-Click Menus 

The XIC, MS2 and mass error, and Isotope plots have a variety of context menus for plot styling and 
exporting revealed by a right-click on the plots: 

 

Figure 114: Plot right-click menus, [1] for MS2 and mass-error plots and [2] for XIC/Isotope plots 
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Figures exported can be useful for reports, publications, regulatory filings, or internal communications. 
There are many options for rendering and exporting so that the user has much freedom to prepare a plot 
or figure style as needed. 

● Adjust X-Y axis limits opens a dialog for the user to manually edit the plots x and y maxima 

and minima. This is a less convenient but more precise (and reproducible) alternative to the  

and  icons. 

● Export image allows the user to save the plot as a *.pdf file or as a *.png, *.wmf or *.svg image 
file. It opens the Plot Exporting Settings dialog, which controls image size, file name and 
folder, and x and y minima and maxima: 

  

Figure 115: Plot export settings 

Sometimes a user wishes to display a wide range across the x-axis and yet retain significant detail. This 
can be done by breaking up the plot into a series of panels. The Add segment button creates 
segments with user-defined x and y values. A series of these segments eliminates unneeded 
portions of the plot and increases the effective detail in the image. This is also a useful function 
for automated reporting. The Re-segment button allows edits to the reported x and y minima 
and maxima for existing segments. 

Note: Image exports also support *.svg image formats. In the file name cell, change the selected 
extension to .svg and click Save: 
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Figure 116: Plot export file options 

● Export image series also opens the Plot Exporting Settings dialog, except that the segments 
are prepopulated with six equal sized segments. This simplifies the edits of the segments. The 
Add segment and Remove segment buttons control the number of segments that divide up the 
plot. 

● Export all also opens the Plot Exporting Settings dialog, except that the wildtype peptide plots 
are exported along with the peptide plots. Segment editing functions are disabled for this option. 

● Export to CSV exports the plot trace x-y points to a *.csv file. 

● Copy to clipboard (all) enables pasting the plot image into another application. 

● Avoid label collision staggers the label text to reduce overlap. 

● Rendering options controls how a plot is displayed in the application. It includes several sub-
menus: 

 

Figure 117: Rendering options menu 

o Preconfigured sub-menus control what is displayed in the plots. Default mode displays 
the trace, peak labels and plot title. Show all peak labels does exactly that. Trace only 
turns off the peak labels and plot title. 

o Show x grid lines turns on and off the x grid lines. 

o Show y grid lines turns on and off the y grid lines. 

o Show tracker displays a vertical dotted line that follows the cursor when moved in the 
plot. This allows a more precise determination of the X and Y positions of the cursor. 

o Y-tick label notation toggles between y-axis notation options of absolute amounts or as 
percentages of the highest peak. 

o Adjust font sizes controls the font size for each type of text on the plot. 

o Plot styles allows changes to the graphic styling of the plot, including trace width, axis 
width, and total m/z dot colors to be used. 
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o First Layer (XIC and Isotope plots only) reveals sub-menus to turn on and off the 
display of traces, integrations, and labels in the plots. The show/hide all sub-menu turns 
all on or off. 

 

Figure 118: Rendering options > First Layer menu 

● Adjust Offset (XIC plots only) sets the x-axis offset between multiple plots as percentage of the 
highest peak when the top-level menu Window > Enable Stacked Plots is checked. 

● Show/hide sample name (XIC and Isotope plots only) controls whether to display the sample 
names or not for both individual and stacked plots. 

● Sample name position (XIC and Isotope plots only) reveals sub-menus to position the 
sample name with respect to the graphs. 

 

Figure 119: Sample name position sub-menu 

XIC Plots and Menu 

The XIC plots view displays chromatograms for specific regions of the peptides and wildtype peptides 
associated with the record selected in the Peptides table:  
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Figure 120: XIC Plots 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
XIC plots: 

● The  icon turns plot annotations on or off. In the XIC plots, annotations are displayed as 
circles at the base of the chromatograms. Dark red circles represent the position of currently 
displayed MS2 scans. Light red circles represent the position of other MS2 scans with the same 
identification. Light gray circles represent the position of MS2 scans with the same precursor 
mass as the selected peptide, but with different attribution. Hover over the circles and the 
associated sequence ID and value are displayed. Note that the cursor changes to a hand. Click 
the circle and the corresponding Peptides table row is selected and the views are updated to 
display for that record.  

● The  icon is used to compute the XIC plot integration for a specified time range. A dialog 
opens to enter start and end times. 

● The  icon enables MS scan extraction. This displays isotope values derived from the XIC 
plot. A blue vertical line appears in the XIC plots view. As the line is dragged across the XIC 
trace, the Isotope plots view is updated to show the MS scan for that XIC time value. Two new 

icons appear on the Isotope plots menu bar in this mode: The  icon clears the extracted MS 

scan and restores the original isotope plots. The  icon saves the extracted MS scan to the 
project document. 

If Window > Enabled Stacked Plots is selected, XIC plots for multiple samples can be overlaid and their 
explicit XIC integration limits defined. 
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Figure 121: Stacked XIC plots 

With stacked plots enabled (via Window> Enable Stacked Plots), users can click and drag integration 
boundaries within XIC plots to simultaneously update start and end times for all samples and charges of 
a peptide. Subsequent changes will be reflected in the Peptides table.  

  

Figure 122: Selection of multiple plots 

The option to edit multiple integration boundaries displayed in a set of stacked XICs at once is available 
with 'Shift+Click' and 'Ctrl+Click' actions. To move all start or end boundaries to the same retention time, 
hold down shift when clicking and dragging a boundary marker.  

Alternatively, holding ctrl when clicking and dragging will result in boundary markers moving by the same 
amount. 

If the user selects Combine Charge States under Edit>Search Filter>Peptide Grouping Method the 
application will display XIC traces for multiple charge states of the same molecule form in a single plot. 
This may provide additional evidence for the identity of the molecule. 
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Figure 123: XIC traces for multiple charge states on one plot 

Isotope Plots and Menu 

The Isotopes plots display the peptide isotope (m/z scan) for the selected Peptides table record:   

 

Figure 124: Isotope plots 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
Isotope plots: 

● The  Show/hide annotations icon turns on and off the display of the molecular weight for the 
primary peptide beside a blue dot that identifies the peak with that calculated value. 
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● The Sum MS1 icon is a local per-peptide summing option that sums MS1 scans for the 
selected peptide. If the XIC interval is adjusted by the user, the isotope plot will update 
accordingly. Note: Scan summing only works on projects created using v4.6 or later of Byos.  

● The  Theoretical isotope distribution icon renders the theoretical averagine distribution. The 
theoretical isotope distribution is calculated using the averagine model rather than the exact 
chemical composition. Theoretical isotope distribution is rendered using green sticks surrounded 
by green shaded transparent rectangular boxes. 

MS2 and Mass Error Plots and Menu 

The MS2 and mass error plots display plots of the MS2 peptide fragments with the corresponding m/z 
mass error table: 

 

Figure 125: MS2 and mass error plots 

The MS2 plots are identified by Scan ID. The plots are colored blue for N-terminus b ions and red for C-
terminus y ions. Other fragments, including c and z ions are colored green 

In addition to the menu icon functions shared by all the plot views, there are some functions specific to 
MS2 and mass error plots: 

● The  icon switches between the default plot view and the mass table view: 
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Figure 126: MS2 and mass error plots: mass table view 

The reported fragment data that was confirmed in the analysis is displayed in red bold font. Unconfirmed 

fragment data is displayed in black font. In this view, the  icon switches the view back to MS2 

plots. The  icon copies the content of this table to the clipboard. 

● The  icon switches between showing and hiding the b and y ion labels. The icon is 
accompanied by a drop-down arrow that reveals three sub-menus: 

o Open annotation options opens a dialog that allows the user to set options for 
determining the assignment of the MS2 annotations: 

 

Figure 127: MS2 fragment annotation options 

The maximum number of peaks per 100 m/z and MS2 mass-accuracy tolerance options can use presets 
for Low accuracy, High accuracy, or Custom, in which the user sets these values. The dialog 
defaults to the Auto preset, in which the software determines the MS2 fragment annotation 
settings. 

o Remove fragment coverage cache clears the existing cache of detected fragments 
used for the protein fragment coverage rendering. 
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o Export fragment to CSV, exports the fragment sequence to a *.csv file. 

o The  icon turns on or off the fragment sequences displayed to the right of the plots. 

The MS2 and mass error plots view has two specific context menu items revealed by a right-click in the 
plot:  

● Apply peak filtering opens a dialog that allows the filtering of peaks by an entered signal-to-
noise ratio value. 

 

Figure 128: Peak filtering by signal-to-noise ratio 

● Combine MS2 spectra (MS2 and mass error plots only) sums the MS2 Plots for all the peptides for 
a selected row in the Peptides table. The title of the plot updates to show the counts of the peptide 
scans in the combined MS2 plot: 

 

Figure 129: MS2 plots after Combine MS2 spectra is applied 

As of Byos v5.9, multiple annotations per peak are now allowed within the annotated MS2 spectrum plot. 

Chromatogram XIC Plot and Menu 

The Chromatogram XIC plot displays the [1] Total Ion Current (TIC), [2] Extracted Ion Chromatogram 
(XIC) of a specific peptide, [3] Summed Extracted Ion Chromatograms (XIC summed) of one or multiple 
peptides eluting at a given time, and the [4] Total Ion Current difference (TIC difference). XIC Summed 
calculation features the core step of the chromatogram XIC plot. This feature helps the user visualize how 
much of the total signal (represented by the TIC) is accounted for by the collection of XICs. TIC difference 
is defined as TIC – XIC Summed. To open the Chromatogram XIC plot, choose Window > Show 
Chromatogram XIC Plot. 

The default view for the Chromatogram XIC plot shows the TIC curve and the XIC curve of all the peptides. 
The two peaks shown for the selected peptide (peaks between magenta lines) are the Total Ion Current 
(no-fill top peak) and Extracted Ion Chromatogram (red-filled bottom peak). 
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Figure 130: Default view of Chromatogram XIC plot 

In addition, XIC Summed and TIC Difference traces can also be overlayed. XIC summed is calculated 
by summing the XICs of isotopes of peptides, including different charge states. TIC difference can then 
be calculated using the formula, TIC – XIC summed. 

In addition to the menu icon functions shared by the other Peptide Analysis plot views, there are some 
functions specific to the Chromatogram XIC plot: 

● The  Settings icon opens the Plot Settings dialog. The dialog includes navigation to four 
areas [a] General, [b] Labels, [c] Summed mode, [d] Zoom options. 

o General – contains options to show and edit the plot title and limit the number of 
displayed peptides: 

 

Figure 131: General tab - Chromatogram XIC plot menu item 

Edit plot title opens the Template Editor dialog: 
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Figure 132: Template Editor within General tab 

The Template Editor allows free entry of a plot title or the use of Short Codes. 

o Labels – contains options to show and edit annotations, limit the total number of labels 
and orient (rotate) labels: 

  

Figure 133: Labels tab - Chromatogram XIC plot menu item 

Edit annotations also opens the Template Editor dialog. The default [PeptidesID] can be replaced 
with other annotations available in the “Short Codes” tab on the Template Editor menu 
(Note: a Chromatogram Analysis license is required to see the Labels section for 
Chromatogram XIC plots). 

 

Figure 134: Edit annotations within Labels tab 

Below are some of the options for the Short Code (1st column). 
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Figure 135: List of options for Short Code 

Selecting the [Sequence] Short Code would result in the below annotation of the peaks. 

 

Figure 136: Selecting [Sequence] Short Code to show peptide sequences as annotations 

o Summed mode – contains the option to select TIC difference calculation, along with 
XIC summed: 
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Figure 137: Summed mode tab - Chromatogram XIC plot menu item 

o Zoom options – contains the standard zoom options, along with scrolling visibility: 

  

Figure 138: Zoom options tab - Chromatogram XIC plot menu item 

● The filter  icon opens the Column Filters Editor dialog. The dialog enables filtering based on 
combinations of column values: 
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Figure 139: Column Filters Editor for filtering data to plot 

● Center X zooms the segment and centers it in the frame: 

 

Figure 140: Center X allows to center the plot on X-axis 

● Center Y, available when Center X is selected, zooms the segment and centers the height of the 
designated peak in the segment in the frame: 

 

Figure 141: Center Y allows to center the plot vertically (i.e., on Y-axis) 

● Summed button features the core step of the chromatogram XIC plot. This feature helps the 
user visualize how much of the total signal (represented by the TIC) is accounted for by the 
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collection of XICs. In addition to the default TIC and XIC layers, additional layer XIC summed is 
generated when Summed icon is clicked. XIC Summed is the sum of all XICs of all the isotopes 
and at different charge states of the peptide. 

 

Figure 142: XIC Summed, TIC Difference and TIC curves 

Note that the calculation of the Summed XIC (and TIC difference, if checkbox is enabled in the  
Settings icon > Summed mode > TIC Difference shown in Figure 137) might take a while 
depending on the size of the raw MS files and the RAM of the desktop computer. 

The traces are plotted as layers (shown in the figure above) and user has an option to pick the set of 
traces to visualize. In the above figure, XIC layer rendering is hidden. This means, except the 
XIC layer, the rest of all of the layers can be seen. 

Appendix 

Advanced Commands 

Peptide Analysis includes many ways to customize the functionality to fit specific needs. Protein Metrics 
uses Advanced Commands to test new ideas, beta-test new features, and enable specialized options, 
without adding complexity to the graphical user interface. This section describes several text-format 
Advanced Commands that will enable finer control over processing. Advanced commands may be entered 
during project creation in the Advanced configuration panel of the Advanced tab or after project creation 
by choosing Edit -> Advanced configuration. 

1. In-silico Align allows shifts in the start and end times to better match the signal. 

FeatureCenterTolerance specifies how much a feature (start and end time pair) may shift in 

minutes. FeatureDurationTolerance specifies how much a feature may grow or shrink in minute. 

[InSilicoAlign] 

FeatureCenterTolerance=1 

FeatureDurationTolerance=0.5 
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Signal processing has been updated in Byos 5.3 to improve the XIC boundary for deamidated 

peptides that closely elute with the wildtype. The processing is automatically used for processing 

deamidated peptides when the following advanced command is applied: 

[InSilicoAlign] 

MultiIsotopeMethod=2 

 

 

[InSilicoAlign] 

FeatureCenterTolerance=1 

FeatureDurationTolerance=0.5 

 

As of Byos v5.4, users can enter the following command to enable multiple improvements in the 

In-silico Align workflow.  

[InSilicoAlign] 

Enabled=true 

 

 

Note: If the in-silico align advanced command is being used, the start and end time of the added 

mass XIC may be different than what was entered by the user, in order to align across samples. 

If a user wants the XIC start and end to exactly match their input, then Add Mass must be done 

without using the in-silico align advanced commands. 

If individual parameters are set in addition to this command, the set value(s) will take precedence. 

2. KeepIsoformOrder improves logic for in-silico isoform assignments. 

[InsilicoAlign] 

KeepIsoformorder=true 

 

In the case of closely eluting isobaric candidates specified in the input CSV (e.g, the various 
deamidated forms of a peptide), the existing In-silico align logic will result in the same bounds for 
each candidate. Using this advanced command, the refined logic will attempt to assign input CSV 
candidates to correct peaks based on the elution order of the LC peaks found in the XIC. In some 
cases, it may also be necessary to include the following command to prevent the need for ‘score’ 
filtering: 

[MSFeatureFinderSeg] 

ScoreNegligibleRatio=-1.0 

 

3. AlwaysAddLabeledPeptide allows correct grouping of in-silico peptides from CSV. These 

peptides will be grouped together with existing peptides unless they differ in retention times, in 

which case they form separate groups. Adding the below advanced command to the project will 

override the default isoD/isoAsp with whatever is in the command line. 

[InSilico] 

AlwaysAddLabeledPeptide=isoAsp|isoD 

 

4. Autosplit automatically splits peptides during project creation if the peptide is wildtype, the 

sequence contains amino acid pairs DG, DS, or DD, and there are XIC proposals. The XIC 

proposals will be consistent across all charged states of the same peptide. New peptides will be 

marked “In-Silico” and a user-defined label will be visible in the Peptides table. In the example 

below, the label will be “IsoAsp”.  
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[Byologic] 

AutoSplitPeptides=DG|DS|DD 

AutoSplitPeptidesLabels=IsoAsp 

; Leave AutoSplitPeptides empty to disable 

 

Note: If AutoSplitPeptides is set to <blank>, the function is disabled. 

5. MS feature align performs a time alignment of all the samples and produces an ensemble average 

of the XIC signal. This reduces some noise and prepares multiple samples to search for XIC start 

and end points in an "ensemble" plot, as opposed to searching each plot separately). In some 

cases, especially with Iso-D, the input sample degrades and peaks may not be found in all 

samples. If MSFeatureAlign is disabled, the Iso-D start and end point proposal in one MS2 file 

sample may not be found in another. In such cases Iso-D splitting will not work. 

MSFeatureAlign is enabled by setting it to one of two modes. For Mode=Full, all peptides will be aligned. 
For Mode=DifferentTopologyOnly, the ensemble average is used if different number of peaks 
are found in the various samples. After the peaks are found in the ensemble XIC, they get 
distributed back to the MS samples. This enables identification of peaks with zero signal 
between the XIC start and end points (e.g. where no lsoD is found). 

[MSFeatureAlign] 

Mode=DifferentTopologyOnly  

OR 

Mode=Full 

 

6. Negligible Ratio settings can help identify very small peaks, (e.g. Iso-D peaks). The values 

assigned are ratios of the main peak; 0.001 is a peak sensitivity of 0.1% of the main peak. 

[MSFeatureFinderSeg] 

AUCNegligibleRatio=0.001 

ScoreNegligibleRatio=0.0005 

 

7. Feature Finder Segments speeds up peak finding and helps identify narrow XIC peaks. 

SmoothingStDev is used to tweak the peak finding algorithm to find narrow peaks. The default of 

0.04 is good for identifying common peaks. A smaller value is better for narrow peaks. 

SamplesPerMinute can be reduced to increase processing speeds. The default rate is 100 

samples per minute, which is generally considered a safe rate. A smaller value will speed up 

processing for large projects with many peptides and samples. 

[MSFeatureFinderSeg] 

SmoothingStDev=0.005 

SamplesPerMinute=50.0 

 

8. Combined MS/MS Spectra configures the number of summed spectra (averaged spectra to be 

annotated with the MS/MS fragments). Changes to this count can be made after processing to 

modify the results. 

[Byologic] 

MS2PeptideCombinedCount=5 

 

9. Auto-Annotate CDRs enables/disables automatic annotation of CDR regions during project 

creation. The CDR regions in antibodies are automatically annotated (set to 1) during project 

creation by default. 

[Byologic] 
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AutoAnnotateCDRs=0 

 

10. Enable XIC Correlation computes XIC cosine correlation between variant and its wildtype peptide. 

This is disabled (set to 0) by default. 

[Byologic] 

EnableXICCorrelation=1 

 

11. Enable MS1 Correlation checks the MS1 isotope distribution. This is disabled (set to 0) by 

default. 

The MS1 isotope envelope confidence column will be added to the Peptides table when this 

advanced command is applied. The MS1 isotope envelope confidence column displays the values 

calculated using the KL metric that is currently used for MS2 fragment isotope confidence, 

normalized to 0-1 scale.  

This metric facilitates better True Positive discrimination, fast calculation, lesser sensitivity of 

occasional interferences on minor isotopes, and better sensitivity to a shifted isotope pattern. 

Additionally, a single threshold can be applied across a wide range of data. 

[Byologic] 

EnableMS1Correlation=1 

 

12. Correcting primary proteins corrects inconsistent protein assignments by assigning the peptide 

in all samples to the highest-ranking protein. If HCP searches against multiple samples yield 

different primary proteins for a given sequence, this can be used to synchronize the samples. 

[Byologic] 

AdjustPrimaryProtein = true; 

 

13. Enable Summary Protein List creates the column Protein summary list in the Peptides table 

to display all protein IDs containing the peptide sequence. Thus, all multiple duplicates of a peptide 

(e.g. in multi-specifics and HCPs) are visible. 

[Byologic] 

EnableSummaryProteinList = true; 

 

14. PeakFindingRange affects in-silico align and these advanced commands should only be used 

when the entire tolerance range specified will only contain the target peptide. In the default 

behavior, the original in-silico start/end time must at least touch a peak to find it. This range can 

then be moved by the user as much as the user-defined tolerance allows. Additional commands 

are as follows: 

For PeakFindingRange=Extended, the most intense peak in the entire range specified by the user-

provided tolerance is found.  

When PeakFindingRange=Soft, distant peaks are gradually de-valued, and a good peak is 

identified as a compromise between time shift and intensity.  

[Byologic] 

PeakFindingRange = Soft; 

OR 

PeakFindingRange = Extended;  

 

15. PeptideMatchPolicy allows the user to assign MS/MS identifications to in-silico peptides within 

the relevant XIC time interval. For example, if a peptide is split, this policy will re-assign MS/MS 



Peptide Analysis Manual v5.12                                         

 

82 

 

identifications based on the new XIC limits of the original and the created in-silico peptide. This 

also helps the user to choose the appropriate MS1 for each peptide. The numbering is in binary, 

with the value of 1 denoting on.  

[Byologic] 

PeptideMatchPolicy=1 

 

16. AddDuplicates controls how homologous peptide sequences are annotated in the Protein 
coverage table. Two options allow Protein coverage to be digestion-aware. 

[ProteinCoverage] 

AddDuplicates = 1 

 

The options for AddDuplicates are: 

o 0 - no duplication 

o 1 - duplication within the same protein 

o 2 - duplication across all proteins 

o 3 - duplication within the same protein applying protease specificity 

o 4 - duplication across all proteins applying protease specificity 

Note: if the advanced command is not used, the default is option 4. The protease is specified in the 
Digestion column in the Sample Input tab during project creation. If no protease is specified 
(i.e, the Digestion column is blank in the Samples table), the project will be created with 

AddDuplicates = 2. 

17. FastXIC accelerates XIC processing. 

[MSReaderDev] 

XicMode = fast 

The following optional settings are available for this command: 

[MSReaderDev] 

FastXicGranularity = 100000 

FastXicMaxMz = 3010 

FastXicMaxIonCount = 2000 

 

Parameter Description 

FastXicGranularity Integer value, relates to the precision. 10000 is 4 places past the 
decimal.  For mass 1000.1236, a granularity of 1000 sets the 
value to 1000.124, while a granularity of 10000 keeps the value 
at 1000.1236. Default value is 100000. 

FastXicMaxMz Integer value. The maximum m/z value during data acquisition. 
To acquire data in the range 200-2000, set FastXicMaxMz = 
2000, so that no ions are acquired past that value. Default value 
is 3010 

FastXicMaxIonCount Integer value. The maximum number of ions to be considered, 
sorted by intensity. Some files may contain ~2500 ions per scan. 
FastXicMaxIonCount = 1000 uses only the top 1000 ions by 
intensity. This is especially important for TOFs with ~25K ions 
per scan, where a higher value of 2500is recommended. Default 
value is 1000. 
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18. AutoSplitWildTypeCoelution captures in-source artifacts and process related modified peptides 
in separate peaks. Additionally, a previous advanced command will now flag in-source artifacts. 

[Byologic] 

AutoSplitWildTypeCoelution=true 

 

19. ReduceInSourceArtifacts eliminates in-source modification artifacts from the XIC boundary 
windows. Potential in-source artifacts are specified by a comma separated list of chemical 
formulae. 

For example, to account for in-source oxidation and dehydration one would use: 

[InsilicoAlign] 

ReduceInSourceArtifacts=O,H(-2)O(-1) 

 

20. ExportBottomUpCsv enables the proper formatting of the 2nd tab in Byologic into a CSV for 
import into either Intact or Byomap within Intact and Charge Variant reconstruction workflows. 

[Report] 

ExportBottomUpCsv=1 

 

  

21. Improvements in XIC trace interval limits of components generated by Feature Finder 

[FeaturesFinderOptions] 

PeakSegmentationMethod=2 

RunInSilicoAlign = false 

 

22. Theoretical fragmentation for HCD data and isotopic distribution plots can be activated 
using the above code in either the project’s advanced configuration or pmi_advanced.ini 

[Byologic] 

FragmentPrediction=true 

IsotopeDistributionPrognosticator=true 

 

23. Balance peptide charges by generating missing XICs using the following advanced command. 
When using this advanced command, in silico peptides will be added to the project so that any 
version of a peptide (unmodified and modified species) will all contain XICs for the same charge 
states, in order to allow for fair relative quantitation calculations across different species of the 
same peptide. 
 
Byologic] 

FillMissingChargeStates=true 

 

 

 


